A maior rede de estudos do Brasil

Grátis
8 pág.
APOL 03- LOGICA DE PROGRAMAÇÃO

Pré-visualização | Página 1 de 1

APOL 03- NOTA 40
Questão 1/5 - Lógica de Programação e Algoritmos
Uma estrutura de repetição é utilizada quando se deseja repetir um trecho do algoritmo, conforme vimos na Aula 5. Uma dos tipos de estrutura de repetição utiliza um número definido de repetições.
Qual seria a melhor estrutura para uma repetição com número definido de repetições?
Nota: 20.0
	
	A
	PARA <variável> de ate [passo] faca 
     <seqüência-de-comandos> 
fimpara
Você acertou!
Aula 05 - Slide 13
	
	B
	PARA <variável> de ate [passo] faca 
     <seqüência-de-comandos> 
fimse
	
	C
	PARAENQUANTO <variável> de ate [passo] faca 
     <seqüência-de-comandos> 
fimpara
	
	D
	SEENQUANTO para <variável> de ate [passo] faca 
     <seqüência-de-comandos> 
fimse
	
	E
	DE <variável> de ate [passo] faca 
     <seqüência-de-comandos> 
fimpara
Questão 2/5 - Lógica de Programação e Algoritmos
Na Aula 6 trabalhamos com o conceito de vetores em psedocódigo. Vetores são variáveis que podem conter diversos valores. 
O algoritmo abaixo realiza a leitura de 10 nomes de pessoas e o seu sexo, e armazena os nomes em 2 vetores diferentes. 
Caso a pessoa seja homem, é armazenada no vetor Vmasc, e caso seja mulher, no vetor Vfem.
Infelizmente, o código contém erros. Assinale a alternativa que identifica todos os erros do código.
Nota: 0.0 
REPOSTA CORRETA- LETRA A
	
	A
	A leitura do Nome e do Sexo devem estar dentro do para-se.
Estão invertidos os vetores de armazenamento dentro do se-faca. Deveria 
ser primeiro o Vmasc e depois oVfem. 
A variável i está declarada errada. Ela deve ser to tipo inteiro.
	
	B
	A leitura do Nome e do Sexo devem estar dentro do para-se.
A variável i está declarada errada. Ela deve ser to tipo inteiro.
	
	C
	A leitura do Nome e do Sexo devem estar dentro do para-se.
Estão invertidos os vetores de armazenamento dentro do se-faca. Deveria 
ser primeiro o Vmasc e depois o Vfem.
	
	D
	O para-se é inapropriado para esta situação. Deve-se utilizar o enquanto-faca.
Estão invertidos os vetores de armazenamento dentro do se-faca. Deveria ser
 primeiro o Vmasc e depois o Vfem. 
A variável i está declarada errada. Ela deve ser to tipo inteiro
	
	E
	O para-se é inapropriado para esta situação. Deve-se utilizar o enquanto-faca.
A variável i está declarada errada. Ela deve ser to tipo inteiro
Questão 3/5 - Lógica de Programação e Algoritmos
Na aula 6 trabalhamos com o conceito de vetores. Considere um vetor de dimensão 10 chamado v1.
Qual seria a lógica mais adequada para fazer a entrada, via teclado, de cada elemento deste vetor v1? Assinale a alternativa correta e assuma que a variável que varre as posições do vetor é a variável pos.
Nota: 0.0
REPOSTA CORRETA- LETRA B
	
	A
	para pos de 1 ate 10 faca
     escreval("Digite um numero qualquer:")
     leia(v1[1])
fimpara
	
	B
	para pos de 1 ate 10 faca
     escreval("Digite um numero qualquer:")
     leia(v1[pos])
fimpara
	
	C
	para pos de 1 ate 10 faca
     escreval("Digite um numero qualquer:")
     leia(v1[10])
fimpara
	
	D
	para pos de 1 ate 10 faca
     escreval("Digite um numero qualquer:")
     leia(v1)
fimpara
	
	E
	para pos de 1 ate 10 faca
     escreval("Digite um numero qualquer:")
fimpara
Questão 4/5 - Lógica de Programação e Algoritmos
O algoritmo abaixo envolve conteúdos como funções de entrada e saída e laços de repetição/iteração.
Assinale a alternativa que contém o enunciado que melhor descreve o funcionamento deste algoritmo.
Nota: 0.0
REPOSTA CORRETA- LETRA A
	
	A
	
	Faça um algoritmo em que o usuário digita inúmeros valores do tipo real e calcula 
a média, a soma deste valores e o total de valores digitados. O programa se encerra
 quando o usuário digitar um valor menor ou igual a zero.
	
	B
	
	Faça um algoritmo em que o usuário digita inúmeros valores do tipo real e calcula
 a soma deste valores e o total de valores digitados. O programa se encerra
 quando o usuário digitar um valor menor ou igual a zero.
	
	C
	
	Faça um algoritmo em que o usuário digita inúmeros valores do tipo inteiro e
 calcula a soma e o total de valores digitados. O programa se encerra quando 
o usuário digitar um valor menor ou igual a zero.
	
	D
	
	Faça um algoritmo em que o usuário digita inúmeros valores do tipo real e 
calcula a média e o total de valores digitados. 
	
	E
	
	Faça um algoritmo em que o usuário digita inúmeros valores do tipo real e
 calcula a média, a soma deste valores e o total de valores digitados.
Questão 5/5 - Lógica de Programação e Algoritmos
Na aula 6 trabalhamos com o conceito de vetores. Considere um vetor de dimensão 50 chamado v1.
Qual seria a melhor lógica para a identificação do menor e do maior elemento deste vetor v1? Assinale a alternativa correta e assuma que a variável que varre as posições do vetor é a variável pos, a variável maior armazena o maior valor do vetor e a variável menor armazena o menor valor do vetor.
Nota: 20.0
	
	A
	  para pos de 1 ate 10 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
 
   fimpara
	
	B
	   maior<-v1[1]
   menor<-v1[1]
 
   para pos de 1 ate 10 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   senao
      menor<-v1[pos]
   fimse
 
   fimpara
	
	C
	   maior<-v1[1]
   menor<-v1[1]
 
   para pos de 1 ate 50 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
 
   fimpara
Você acertou!
	
	D
	   maior<-v1[1]
   menor<-v1[1]
 
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
	
	E
	   maior<-v1[pos]
   menor<-v1[pos]
 
   para pos de 1 ate 50 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
 
   fimpara

Crie agora seu perfil grátis para visualizar sem restrições.