A maior rede de estudos do Brasil

ALGORITMO EM VISUALG

Implementar, na ferramenta VisuAlg, um algoritmo completo para resolver um determinado problema. Neste caso, entende-se por algoritmo completo, aquele que faça uso de todos os itens estudados durante a disciplina e descritos no item “a” deste documento.

O algoritmo implementado deve fazer uso de todos os seguintes recursos: 

*declaração de variáveis. 

*comandos de leitura(leia) e escrita(escreval).

*estrutura condicional (se ou caso/escolha).

*estrutura de repetição (para, repita ou enquanto).

*uso de conjuntos(vetor ou matriz) para armazenamento de dados.

 

Lógica de Programação

IF SUL DE MINAS


2 resposta(s)

User badge image

Eduardo Teixeira

Há mais de um mês

Vê aí se da pra te ajudar.

algoritmo "Multicaixa"
// Autor: EDUARDO TEIXEIRA
// Descrição: Aplicação visual g

funcao GerarConta : inteiro
var
inicio
numeroCont := numeroCont + 1
retorne numeroCont
fimfuncao

procedimento CadastroConta
var
a: caractere
j: inteiro
inicio
limpatela
Escolha(GerarConta())
caso 0
Escreval ("O sistema está desconectado, reinicie e tente novamente!")
outrocaso
para j de numeroCont ate numeroCont faca
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Criar conta - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreval(" ________________________________________")
numeroConta[j] := j
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[j])
Escreva ("| - NOME: ")
leia(nomeCliente[j])
Escreva ("| - SENHA: ")
leia(senhaCliente[j])
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuAdministrador()
fimpara
fimescolha

fimprocedimento
procedimento ListagemDeClientes()
var
contCli : inteiro
a : caractere
inicio
limpatela
contCli := 0
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Lista de Clientes - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
para contCli de 0 ate numeroCont faca

Escreval("| - NÚMERO DA CONTA: ",numeroConta[contCli])
Escreval("| - NOME: ",nomeCliente[contCli])
Escreval("-----------------------------------------------------------------------------------")
fimpara
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuAdministrador()
fimprocedimento

procedimento MenuAdministrador()
var
inicio
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Atualizado em 14, Fevereiro de 2017")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval(" | |")
Escreval(" | 0 - CADASTRAR NOVA CONTA |")
Escreval(" | 1 - LISTAR CADASTRADOS |")
Escreval(" | X - SAIR |")
Escreval(" |________________________________________|")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreva("Informe uma operação: ")
leia(operadorAdmin)
escolha(operadorAdmin)
caso "0"
CadastroConta()
caso "1"
ListagemDeClientes()
interrompa
caso "x"
MenuCaixa()
interrompa
fimescolha
fimprocedimento

funcao VerificarValor (numero: real) : logico
var
operacaoFim : logico
aux : real
inicio
// SAQUE
aux := 0
escolha(operador)
caso "0"
para numeroCont de numeroCont ate numeroCont faca
aux := saldoCliente[numeroCont] - numero
se (aux >= 0) entao
saldoCliente[numeroCont] := aux
operacaoFim := verdadeiro
senao
operacaoFim := falso
fimse
fimpara
// DEPÓSITO
caso "1"
se (numero > 0 ) entao
para numeroCont de numeroCont ate numeroCont faca
saldoCliente[numeroCont] := saldoCliente[numeroCont] + numero
fimpara
operacaoFim := verdadeiro
senao
operacaoFim := falso
fimse
fimescolha
retorne operacaoFim
fimfuncao

procedimento MenuCaixa()
var
inicio
repita
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Atualizado em 14, Fevereiro de 2017")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval(" | |")
Escreval(" | 0 - SAQUE |")
Escreval(" | 1 - DEPÓSITO |")
Escreval(" | X - EXTRATO |")
Escreval(" |________________________________________|")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreva("Informe uma operação: ")
leia(operador)
escolha(operador)
caso "0"
ContaBanco()
interrompa
caso "1"
ContaBanco()
interrompa
caso "x"
ContaBanco()
interrompa
caso "H"
MenuAdministrador()
fimescolha
ate((operador = "0") ou (operador = "1") ou (operador ="x"))
fimrepita
fimprocedimento

funcao VerificarConta (numero : inteiro; senha : caractere): logico
var
contaEncontrada : logico
contadorVerifica : inteiro
inicio
para contadorVerifica de 0 ate numeroCont faca
se nao(numero <> numeroConta[contadorVerifica]) entao
se (senhaCliente[contadorVerifica] = senha) entao
contaEncontrada := verdadeiro
fimse
senao
contadorVerifica := contadorVerifica + 1
fimse
fimpara
retorne contaEncontrada
fimfuncao

procedimento ContaBanco()
var
inicio
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval("| |")
Escreval("| - Informe o número da conta:")
leia(numeroCont)
Escreval("| - Informe a senha:")
leia(senhaUse)
Escreval("| |")
Escreval("|________________________________________|")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
escolha (VerificarConta(numeroCont,senhaUse))
caso verdadeiro
escolha(operador)
caso "0"
SaqueConta()
interrompa
caso "1"
DepositoConta()
interrompa
caso "X"
ExtratoConta()
interrompa
fimescolha
outrocaso
timer(1000)
Escreval("Conta não encontrada!")
timer(0)
MenuCaixa()
fimescolha
fimprocedimento

procedimento DepositoConta()
var
a : caractere
valorInserir : real
inicio
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Operação Depósito - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreval(" ________________________________________")
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[numeroCont])
Escreval("| - NOME: ", nomeCliente[numeroCont] )
Escreval("| - SALDO ATUAL R$: ", saldoCliente[numeroCont]:2)
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("| Informe o valor: R$ ")
leia(valorInserir)
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
se(VerificarValor(valorInserir) <> falso) entao
Escreval ("Operação realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
senao
Escreval ("Operação não foi realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
fimse
fimprocedimento

procedimento SaqueConta()
var
a : caractere
valorInserir : real
inicio
limpatela
valorInserir := 0
para numeroCont de numeroCont ate numeroCont faca
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Operação Saque - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreval(" ________________________________________")
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[numeroCont])
Escreval("| - NOME: ", nomeCliente[numeroCont] )
Escreval("| - SALDO ATUAL R$: ", saldoCliente[numeroCont]:2)
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("| Informe o valor: R$ ")
leia(valorInserir)
Escreval()
Escreval("-----------------------------------------------------------------------------------")
se(VerificarValor(valorInserir) <> falso) entao
Escreval ("Operação realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
senao
Escreval ("Operação não foi realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
fimse
fimprocedimento

procedimento ExtratoConta()
var
a : caractere
inicio
limpatela
para numeroCont de numeroCont ate numeroCont faca
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[numeroCont])
Escreval("| - NOME: ", nomeCliente[numeroCont] )
Escreval("| - SALDO R$: ", saldoCliente[numeroCont]:2)
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
fimprocedimento

var
// Dados para contas de clientes
nomeCliente,senhaCliente: vetor[0..20] de caractere
saldoCliente: vetor[0..20] de real
numeroConta: vetor[0..20] de inteiro
// Operações administradoras
operador,operadorAdmin : caractere
// Contador de cadastros
numeroCont : inteiro
// Variável para guardar a senha digita dentro da funcão de verificação
senhaUse : caractere
inicio
nomeCliente[0] := "Administrador"
saldoCliente[0] := 0
numeroConta [0] := 0
senhaCliente[0] := "Admin"
// CADASTRO DE USUÁRIOS
MenuCaixa()
fimalgoritmo

Vê aí se da pra te ajudar.

algoritmo "Multicaixa"
// Autor: EDUARDO TEIXEIRA
// Descrição: Aplicação visual g

funcao GerarConta : inteiro
var
inicio
numeroCont := numeroCont + 1
retorne numeroCont
fimfuncao

procedimento CadastroConta
var
a: caractere
j: inteiro
inicio
limpatela
Escolha(GerarConta())
caso 0
Escreval ("O sistema está desconectado, reinicie e tente novamente!")
outrocaso
para j de numeroCont ate numeroCont faca
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Criar conta - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreval(" ________________________________________")
numeroConta[j] := j
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[j])
Escreva ("| - NOME: ")
leia(nomeCliente[j])
Escreva ("| - SENHA: ")
leia(senhaCliente[j])
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuAdministrador()
fimpara
fimescolha

fimprocedimento
procedimento ListagemDeClientes()
var
contCli : inteiro
a : caractere
inicio
limpatela
contCli := 0
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Lista de Clientes - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
para contCli de 0 ate numeroCont faca

Escreval("| - NÚMERO DA CONTA: ",numeroConta[contCli])
Escreval("| - NOME: ",nomeCliente[contCli])
Escreval("-----------------------------------------------------------------------------------")
fimpara
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuAdministrador()
fimprocedimento

procedimento MenuAdministrador()
var
inicio
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Atualizado em 14, Fevereiro de 2017")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval(" | |")
Escreval(" | 0 - CADASTRAR NOVA CONTA |")
Escreval(" | 1 - LISTAR CADASTRADOS |")
Escreval(" | X - SAIR |")
Escreval(" |________________________________________|")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreva("Informe uma operação: ")
leia(operadorAdmin)
escolha(operadorAdmin)
caso "0"
CadastroConta()
caso "1"
ListagemDeClientes()
interrompa
caso "x"
MenuCaixa()
interrompa
fimescolha
fimprocedimento

funcao VerificarValor (numero: real) : logico
var
operacaoFim : logico
aux : real
inicio
// SAQUE
aux := 0
escolha(operador)
caso "0"
para numeroCont de numeroCont ate numeroCont faca
aux := saldoCliente[numeroCont] - numero
se (aux >= 0) entao
saldoCliente[numeroCont] := aux
operacaoFim := verdadeiro
senao
operacaoFim := falso
fimse
fimpara
// DEPÓSITO
caso "1"
se (numero > 0 ) entao
para numeroCont de numeroCont ate numeroCont faca
saldoCliente[numeroCont] := saldoCliente[numeroCont] + numero
fimpara
operacaoFim := verdadeiro
senao
operacaoFim := falso
fimse
fimescolha
retorne operacaoFim
fimfuncao

procedimento MenuCaixa()
var
inicio
repita
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Atualizado em 14, Fevereiro de 2017")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval(" | |")
Escreval(" | 0 - SAQUE |")
Escreval(" | 1 - DEPÓSITO |")
Escreval(" | X - EXTRATO |")
Escreval(" |________________________________________|")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreva("Informe uma operação: ")
leia(operador)
escolha(operador)
caso "0"
ContaBanco()
interrompa
caso "1"
ContaBanco()
interrompa
caso "x"
ContaBanco()
interrompa
caso "H"
MenuAdministrador()
fimescolha
ate((operador = "0") ou (operador = "1") ou (operador ="x"))
fimrepita
fimprocedimento

funcao VerificarConta (numero : inteiro; senha : caractere): logico
var
contaEncontrada : logico
contadorVerifica : inteiro
inicio
para contadorVerifica de 0 ate numeroCont faca
se nao(numero <> numeroConta[contadorVerifica]) entao
se (senhaCliente[contadorVerifica] = senha) entao
contaEncontrada := verdadeiro
fimse
senao
contadorVerifica := contadorVerifica + 1
fimse
fimpara
retorne contaEncontrada
fimfuncao

procedimento ContaBanco()
var
inicio
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval("| |")
Escreval("| - Informe o número da conta:")
leia(numeroCont)
Escreval("| - Informe a senha:")
leia(senhaUse)
Escreval("| |")
Escreval("|________________________________________|")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
escolha (VerificarConta(numeroCont,senhaUse))
caso verdadeiro
escolha(operador)
caso "0"
SaqueConta()
interrompa
caso "1"
DepositoConta()
interrompa
caso "X"
ExtratoConta()
interrompa
fimescolha
outrocaso
timer(1000)
Escreval("Conta não encontrada!")
timer(0)
MenuCaixa()
fimescolha
fimprocedimento

procedimento DepositoConta()
var
a : caractere
valorInserir : real
inicio
limpatela
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Operação Depósito - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreval(" ________________________________________")
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[numeroCont])
Escreval("| - NOME: ", nomeCliente[numeroCont] )
Escreval("| - SALDO ATUAL R$: ", saldoCliente[numeroCont]:2)
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("| Informe o valor: R$ ")
leia(valorInserir)
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
se(VerificarValor(valorInserir) <> falso) entao
Escreval ("Operação realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
senao
Escreval ("Operação não foi realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
fimse
fimprocedimento

procedimento SaqueConta()
var
a : caractere
valorInserir : real
inicio
limpatela
valorInserir := 0
para numeroCont de numeroCont ate numeroCont faca
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Operação Saque - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval()
Escreval(" ________________________________________")
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[numeroCont])
Escreval("| - NOME: ", nomeCliente[numeroCont] )
Escreval("| - SALDO ATUAL R$: ", saldoCliente[numeroCont]:2)
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("| Informe o valor: R$ ")
leia(valorInserir)
Escreval()
Escreval("-----------------------------------------------------------------------------------")
se(VerificarValor(valorInserir) <> falso) entao
Escreval ("Operação realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
senao
Escreval ("Operação não foi realizada com sucesso!")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
fimse
fimprocedimento

procedimento ExtratoConta()
var
a : caractere
inicio
limpatela
para numeroCont de numeroCont ate numeroCont faca
Escreval("____________________________________________________________________________________")
Escreval()
Escreval(" - SISTEMA BANCÁRIO - BMB(BANCO MUNICIPAL BRASILEIRO) - ")
Escreval()
Escreval(" - Bem Vindo - SISTEMA BMB VERSÃO [1.0.0.0] - ")
Escreval()
Escreval(" Todos os direitos reservados para NORTEC LTDA DESENVOLVIMENTO")
Escreval()
Escreval(" Copyright © 2016-2017 | NORTEC DESENVOLVIMENTO")
Escreval("-----------------------------------------------------------------------------------")
Escreval(" ________________________________________")
Escreval("| ")
Escreval("| - NÚMERO DA CONTA: ",numeroConta[numeroCont])
Escreval("| - NOME: ", nomeCliente[numeroCont] )
Escreval("| - SALDO R$: ", saldoCliente[numeroCont]:2)
Escreval("| ")
Escreval("|________________________________________")
Escreval()
Escreval("-----------------------------------------------------------------------------------")
Escreval("Pressione qualquer tecla para finalizar.")
leia(a)
MenuCaixa()
fimprocedimento

var
// Dados para contas de clientes
nomeCliente,senhaCliente: vetor[0..20] de caractere
saldoCliente: vetor[0..20] de real
numeroConta: vetor[0..20] de inteiro
// Operações administradoras
operador,operadorAdmin : caractere
// Contador de cadastros
numeroCont : inteiro
// Variável para guardar a senha digita dentro da funcão de verificação
senhaUse : caractere
inicio
nomeCliente[0] := "Administrador"
saldoCliente[0] := 0
numeroConta [0] := 0
senhaCliente[0] := "Admin"
// CADASTRO DE USUÁRIOS
MenuCaixa()
fimalgoritmo

User badge image

Dave Rützen

Há mais de um mês

Espero que ajude :)

var
fatzero:vetor [1..10] de real
fatum:vetor [1..10] de real
opcao:inteiro
i:inteiro
somazero:real
somaum:real
inicio
somazero <- 0
somaum <- 0
Para i de 1 ate 10 faca
Escreval("Informe o tipo de pessoa:")
Escreval("")
Escreval("[0] = Pessoa física")
Escreval("[1] = Juridica")
Escreval("")
Escreva("Digite sua opção: ")
Leia(opcao)
Escreval("------------------------------------")
Se (opcao = 0 ) entao
Escreva("Informe o número do faturamento anual: ")
Leia(fatzero[i])
Senao
Escreva("Informe o número do faturamento anual: ")
Leia(fatum[i])
fimse
limpatela
somazero <- somazero + fatzero[i]
somaum <- somaum + fatum[i]
fimpara
limpatela
Se (somazero < somaum) entao
Escreval("O maior faturamento é da pessoa juridica")
Escreval("")
senao
Escreval("O maior faturamento é da pessoa física")
Escreval("")
fimse
Se (somazero > somaum) entao
Escreval("O menor faturamento é da pessoa juridica")
Escreval("")
senao
Escreval("O menor faturamento é da pessoa física")
Escreval("")
fimse
Escreval("A média do faturamento da pessoa fisica é:",somazero/10)
Escreval("A média do faturamento da pessoa juridica é:",somaum/10)
fimalgoritmo

Essa pergunta já foi respondida por um dos nossos estudantes