A maior rede de estudos do Brasil

Pseudocódigo para números primos

Desenvolva em pseudocódigo um algoritmo tenha como entrada um número e que tenha como saída um aviso se o número digitado é primo ou não é primo. Um número Inteiro positivo é primo se ele só for divisível (sem resto) por ele mesmo ou pelo número um (se este for considerado um número primo).


4 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Inicialmente devemos declarar as variáveis que serão utilizadas.

numero,cont,i:inteiro


Agora devemos receber o número que o usuário deverá digitar.

Ler(numero)


Com isso, devemos verificar se o número é primo ou não dividindo o mesmo pro todos seus antecedente e verificando o resto da divisão.

Faca i de 1:numero

se numero%2==0 entao

cont=cont+1

fimse

se cont=2 entao

escreva(“O número é primo”)

senão

escreva(“O número não é primo”)

fimse

fimfaca

Inicialmente devemos declarar as variáveis que serão utilizadas.

numero,cont,i:inteiro


Agora devemos receber o número que o usuário deverá digitar.

Ler(numero)


Com isso, devemos verificar se o número é primo ou não dividindo o mesmo pro todos seus antecedente e verificando o resto da divisão.

Faca i de 1:numero

se numero%2==0 entao

cont=cont+1

fimse

se cont=2 entao

escreva(“O número é primo”)

senão

escreva(“O número não é primo”)

fimse

fimfaca

User badge image

Guilherme Adriano Silva

Há mais de um mês

var
x,y,cont:inteiro
inicio
escreva("Digite um numero:")
leia (x)
cont<-2
repita
se cont=x entao
interrompa
senao
se x mod cont=0 entao
y<-1
interrompa
senao
y<-2
fimse
fimse
cont<-cont+1
fimrepita
se y=1 entao
escreval ("Não é um número primo")
senao
escreval ("É umm numero primo")
fimse
fimalgoritmo

User badge image

Andre Smaira

Há mais de um mês

Inicialmente devemos declarar as variáveis que serão utilizadas.

numero,cont,i:inteiro


Agora devemos receber o número que o usuário deverá digitar.

Ler(numero)


Com isso, devemos verificar se o número é primo ou não dividindo o mesmo pro todos seus antecedente e verificando o resto da divisão.

Faca i de 1:numero

se numero%2==0 entao

cont=cont+1

fimse

se cont=2 entao

escreva(“O número é primo”)

senão

escreva(“O número não é primo”)

fimse

fimfaca

User badge image

Andre Smaira

Há mais de um mês

Inicialmente devemos declarar as variáveis que serão utilizadas.

numero,cont,i:inteiro


Agora devemos receber o número que o usuário deverá digitar.

Ler(numero)


Com isso, devemos verificar se o número é primo ou não dividindo o mesmo pro todos seus antecedente e verificando o resto da divisão.

Faca i de 1:numero

se numero%2==0 entao

cont=cont+1

fimse

se cont=2 entao

escreva(“O número é primo”)

senão

escreva(“O número não é primo”)

fimse

fimfaca

Essa pergunta já foi respondida por um dos nossos especialistas