Prova Discursiva Lógica de Programação e Algoritmos - NOTA 100
5 pág.

Prova Discursiva Lógica de Programação e Algoritmos - NOTA 100


DisciplinaLógica de Programação e Algoritmos2.863 materiais32.689 seguidores
Pré-visualização1 página
10/04/17 22(44AVA UNIVIRTUS
Página 1 de 5http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/59891/novo/1/{idAvaliacaoVinculada}
Matriz Discursiva UTA A FASE I \u2013 21/03 até 08/04 [O aluno poderá estar utilizando o Software VisuALG]
PROTOCOLO: 20160327119079777A6C0FABIO ALVES DA SILVA GOMES - RU: 1190797 Nota: 100
Disciplina(s):
Lógica de Programação e Algoritmos
Data de início: 01/04/2016 17:35
Prazo máximo entrega: 01/04/2016 19:05
Data de entrega: 01/04/2016 18:02
Questão 1/5
Dentro da maneira como o computador manipula informações, numa linguagem de programação há tipos primitivos 
básicos utilizados para construção de programas. Quais são?
Nota: 20.0
Resposta:
São os tipos inteiro, caracter, real e lógico.
Questão 2/5
Escreva um algoritmo para calcular a área de num quadrado.
Nota: 20.0
Resposta:
algoritmo
var
São os tipos inteiro, caracter, real e lógico.
Conteúdo da Aula 3, Slide 3.
\ufffd
algoritmo "Quadrado"
// Seção de Declarações
var
 lado, area: real
 
inicio
// Seção de Comandos
 escreval("Digite o valor para um lado: ")
 leia(lado)
 area<-lado*lado
 escreval(&quot;Area do quadrado=&quot;,area)
 
fimalgoritmo
Conteúdo da Aula 5.
\ufffd
10/04/17 22(44AVA UNIVIRTUS
Página 2 de 5http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/59891/novo/1/{idAvaliacaoVinculada}
largura, comprimento, area:inteiro
escreval(&quot;digite a largura&quot;)
leia (a largura)
escreval(&quot;digite o comprimento&quot;)
leia (o comprimento)
area=largura*comprimento
escreval(&quot;a area do quadrilatero corresponde a &quot;+a)
fimalgoritmo
Questão 3/5
Faça um algoritmo que leia dados para um vetor de n elementos. Após a leitura de todos os elementos do vetor, o 
mesmo deverá pedir uma posição neste vetor e um novo valor. O algoritmo deverá incluir nesta posição este novo valor. 
Logo, os demais valores do vetor deverão ser empurrados para as próximas posições do vetor.
Nota: 20.0
algoritmo &quot;vetores&quot;
var
 
 i,n,posicao : inteiro
 valor:real
 v: vetor [1..50] de real
 
 aux: real
 
inicio
//seção de comandos
 
 escreval(&quot;Digite o número de elementos do vetor:&quot;)
 leia(n)
 para i de 1 ate n faca
 escreval(&quot;Digite um numero qualquer:&quot;)
 leia(v[i])
 fimpara
 
 escreval(&quot;Digite um valor qualquer para inserir no vetor:&quot;)
 leia(valor)
 escreval(&quot;Digite a posição do vetor&quot;)
 leia(posicao)
 
 para i de n ate 2 passo -1 faca
 se (i>=posicao) entao
 v[i+1]<-v[i]
 fimse
 se (posicao=i) entao
 v[i]<-valor
\ufffd
10/04/17 22(44AVA UNIVIRTUS
Página 3 de 5http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/59891/novo/1/{idAvaliacaoVinculada}
Resposta:
algoritmo &quot;vetores&quot;
var
i,n,posicao:inteiro
valor:real
v:vetor[1..50] de real
aux:real
inicio
//seção de comandos
escreval(&quot;digite o numero de elementos do vetor:&quot;)
leia(n)
para i de 1 ate n faca
escreval(&quot;Digite um numero qualquer:&quot;)
leia(v[i])
fimpara
escreval(&quot;digite um valor qualquer para inserir no vetor:&quot;)
leia(valor)
escreval(&quot;digite a posicao do vetor:&quot;)
leia(posicao)
para i de n ate 2 passo -1 faca
se (i>=posicao) entao
v[i+1]<-v[i]
fimse
se (posicao=i) entao
v[i]<-valor
fimse
fimpara
para i de 1 ate n+1 de faca
escreval(v[i])
fimpara
fimalgoritmo
 fimse
 
 fimpara
 
 para i de 1 ate n+1 faca
 escreval(v[i])
 fimpara
 
fimalgoritmo
Conteúdo das Aulas 9 e 10.
10/04/17 22(44AVA UNIVIRTUS
Página 4 de 5http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/59891/novo/1/{idAvaliacaoVinculada}
Questão 4/5
Para manipulação de dados dentro de nossos algoritmos utilizamos quais elementos? Explique cada um.
Nota: 20.0
Resposta:
Variáveis e constantes. Variáveis que são alteradas constantemente no decorrer do tempo de execução dos 
algoritmos e constantes, que não sofrem variação no decorrer do tempo de execução do algoritmo.
Questão 5/5
Faça um algoritmo que leia n números. Exiba a soma dos quadrados de todos os números.
Nota: 20.0
Variáveis e Constantes. Variáveis que são alteradas constantemente no decorrer do tempo de execução dos algoritmos e
constantes, que não sofrem variação no decorrer do tempo de execução do algoritmo.
Conteúdo da Aula 3, Slide 6.
\ufffd
algoritmo &quot;Soma_quadrados&quot;
// Seção de Declarações
var
n,i:inteiro
soma,valor:real
 
inicio
// Seção de Comandos
 
escreval(&quot;Soma dos Quadrados&quot;)
 
escreval(&quot;&quot;)
escreval(&quot;Digite o número de valores:&quot;)
leia(n)
escreval(&quot;&quot;)
 
soma<-0
para i de 2 ate n faca
 escreval(&quot;Digite um valor:&quot;)
 leia(valor)
 soma<-soma+(valor*valor)
fimpara
 
escreval(&quot;Soma dos quadrados=&quot;,soma)
 
\ufffd
10/04/17 22(44AVA UNIVIRTUS
Página 5 de 5http://univirtus-277877701.sa-east-1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/59891/novo/1/{idAvaliacaoVinculada}
Resposta:
algoritmo &quot;soma_quadrados&quot;
// Seção de Declarações
var
n,i:inteiro
soma,valor:real
inicio
//Seção de Comandos
escreval(&quot;Soma dos quadrados&quot;)
escreva(&quot;&quot;)
escreval(&quot;digite o numero de valores:&quot;)
leia(n)
escreval(&quot;&quot;)
soma<-0
para i de 2 ate n faca
escreval(&quot;digite um valor:&quot;)
leia(valor)
soma<-soma+(valor*valor)
fimpara
escreval(&quot;soma dos quadrados=&quot;,soma)
fimalgoritmo
fimalgoritmo
Conteúdo das Aulas 5 e 6.