A maior rede de estudos do Brasil

Grátis
51 pág.
Algoritmo

Pré-visualização | Página 5 de 12

do algoritmo seguirá até o fim do bloco de decisão. 
Essa estrutura é representada por um comando que avalia uma expressão lógica resultando num 
valor verdadeiro ou falso. A seguir, será apresentada a sintaxe da estrutura em pseudocódigo e 
fluxograma, vale lembrar que, por comodidade, apenas a estrutura é apresentada em forma de 
pseudocódigo e fluxograma, e não um algoritmo completo. Que segue as regras descritas anteriormente. 
Modelo Geral: 
 Pseudocódigo Fluxograma 
 
 
 
 
 
 
 
Exemplo usando variáveis: 
 Pseudocódigo Fluxograma 
 
 
 
 
 
 
 Seleção Composta 
A seleção composta é utilizada quando ocorre uma situação em que duas alternativas dependem da 
mesma condição, ou seja, se a condição for verdadeira, um conjunto de ações é executado e, se a condição 
for falsa, outro conjunto de ações é executado. Considere a sintaxe abaixo, lembrando que a representação 
diz respeito apenas ao trecho da estrutura e não ao algoritmo completo. 
se <condição> então 
 <conjunto de ações> 
fim se 
conjunto de 
ações 
condição 
S 
N 
se (A > B) então 
 escreva ( “A é Maior” ) 
fim se 
S 
N 
A > B “A é Maior” 
21 
INTRODUÇÃO À CIÊNCIA DA COMPUTAÇÃO Profa. Dra. Alessandra Bonato Altran 
Modelo Geral: 
 Pseudocódigo Fluxograma 
 
 
 
 
 
 
 
 
Exemplo usando variáveis: 
 Pseudocódigo Fluxograma 
 
 
 
 
 
 
 
 
 Pode ocorrer também a utilização de vários testes de seleção, tanto simples, quanto composta, ao 
mesmo tempo, num mesmo algoritmo. Em outras palavras, é possível que se tenha uma sequência de 
testes de seleção, os quais serão executados ou não, de acordo com os resultados das condições, assim, 
quando as seleções estão dispostas dessa forma, diz-se que essas seleções são encadeadas. 
As seleções podem ser encadeadas de diversas formas, quando estas seguem um padrão lógico diz-
se que a seleção é encadeada homogênea, quando não seguem esse padrão lógico, a seleção é encadeada 
heterogênea. 
A seguir, será apresentada a sintaxe da estrutura de seleção encadeada. Neste caso, a segunda 
condição só será analisada caso o resultado da primeira condição for verdadeiro, pois, uma condição é 
interna à outra. Assim, a obrigatoriedade da análise das duas condições não ocorre. 
 
 
se <condição> então 
 <conjunto de ações 1> 
senão 
 <conjunto de ações 2> 
fim se 
conjunto de 
ações 1 
condição 
S N conjunto de 
ações 2 
se (A > B) então 
 escreva ( “A é Maior” ) 
senão 
 escreva ( “B é Maior” ) 
fim se 
A > B 
S N “B é Maior” “A é Maior” 
22 
INTRODUÇÃO À CIÊNCIA DA COMPUTAÇÃO Profa. Dra. Alessandra Bonato Altran 
 Pseudocódigo Fluxograma 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Exemplo: 
 
 
 
 
 
 
 
 
 
 
 
 
Por outro lado, existem casos em que a variável assume apenas um valor para cada estrutura, ou 
seja, uma estrutura de seleção é localizada após a outra, ocorrendo à obrigatoriedade da análise das duas 
condições, pois, uma não depende da outra. Veja então como fica: 
 
se <condição 1> então 
 se <condição 2> então 
 <conjunto de ações 1> 
 senão 
 <conjunto de ações 2> 
 fim se 
senão 
 <conjunto de ações 3> 
fim se 
conjunto de 
ações 3 
conjunto de 
ações 1 
condição 1 
N S 
condição 2 
N S 
conjunto de 
ações 2 
se (A > B) então 
 se (B > C) então 
 escreva ( “C é Menor” ) 
 senão 
 escreva ( “B é Menor” ) 
 fim se 
senão 
 escreva ( “A é Menor” ) 
fim se 
A > B 
N S 
B > C 
N S “A é Menor” 
 “C é Menor” “B é Menor” 
23 
INTRODUÇÃO À CIÊNCIA DA COMPUTAÇÃO Profa. Dra. Alessandra Bonato Altran 
 Pseudocódigo Fluxograma 
 
 
 
 
 
 
 
 
 
 
Exemplo: 
 
 
 
 
 
 
 
 
 
Observação: Quando isso acontece, a seleção é dita de múltipla escolha. 
 ESTRUTURA DE REPETIÇÃO 
São estruturas que permitem a repetição controlada por comandos, utilizadas quando se tem a 
necessidade de repetir certo trecho de ações por um determinado número de vezes. Esse número de 
repetições pode, ou não, ser conhecido, porém, deverá ser finito. 
A esses trechos que serão repetidos, dá-se o nome de laços repetitivos, sendo estes, divididos em 
laços contados, quando se conhece previamente o número de vezes em que as ações serão repetidas; e 
laços condicionais, quando se conhece a condição para que a repetição aconteça. 
Em alguns casos, faz-se necessário a utilização uma variável que auxilie na contagem do número 
de vezes a ser repetido, essa variável é denominada contador. O conteúdo armazenado no contador é 
alterado pelo seu próprio valor adicionado, ou subtraído, de uma constante. 
se <condição 1> então 
 <conjunto de ações 1> 
fim se 
se <condição 2> então 
 <conjunto de ações 2> 
fim se 
se (A = 1) então 
 escreva ( “Um” ) 
fim se 
se (A = 2) então 
 escreva ( “Dois” ) 
fim se 
conjunto de 
ações 1 
condição 1 
S 
N 
conjunto de 
ações 2 
condição 2 
S 
N 
S 
N 
A = 1 “Um” 
S 
N 
A = 2 “Dois” 
24 
INTRODUÇÃO À CIÊNCIA DA COMPUTAÇÃO Profa. Dra. Alessandra Bonato Altran 
 
nome_contador ← nome_contador + (ou -) constante 
Exemplos: 
cont ← cont + 1 
c ← c + 2 
a ← a – 1 
contador ← contador – 2 
Observação: O contador é uma variável como qualquer outra, por isso tem, obrigatoriamente, que ser 
declarada. Não se pode deixar de salientar que um contador deve ser iniciado com algum valor, já que, 
durante a contagem, ele depende do próprio valor. 
 Outra variável de apoio utilizada é o acumulador que, diferente do contador, tem seu valor 
alterado pelo próprio valor adicionado, ou subtraído, de uma variável, e não de uma constante como o 
contador. O acumulador também tem que ser iniciado, porém, com o valor nulo (zero). 
nome_acumulador ← nome_acumulador + (ou -) variável 
Exemplos: 
acum ← acum + soma 
s ← s + a 
f ← f – k 
acumulador ← acumulador + m 
Assim como as estruturas de seleção, nas estruturas de repetição também são analisadas condições; 
tais condições determinam o critério de parada para o laço repetitivo, ou seja, determinam o momento em 
que a repetição deve terminar. Sendo assim, existem formas diferentes para se organizar essas condições, 
levando à definição de três estruturas diferentes para a repetição, sendo estas: estrutura de repetição com 
teste inicial; estrutura de repetição com teste final e estrutura de repetição determinística. 
 Repetição com Teste Inicial 
 A repetição com teste inicial é utilizada quando ocorre a repetição de um mesmo trecho do 
algoritmo por diversas vezes, porém, com a necessidade da verificação da condição antes de entrar no laço 
repetitivo, isto é, a condição é testada inicialmente. 
25 
INTRODUÇÃO À CIÊNCIA DA COMPUTAÇÃO Profa. Dra. Alessandra Bonato Altran 
Veja, a seguir, como ocorre a representação dessa estrutura em pseudocódigo e em fluxograma: 
 Pseudocódigo