A maior rede de estudos do Brasil

algoritmo

1. Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor zero e imprimir o resultado da divisão do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura FACA) .

2. Reescreva o exercício anterior utilizando a estrutura ENQUANTO. 


2 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

1 - 

Você tem que fazer a consistencia logo após a entrada de dados, assim:

Inicio
	repita
		leia(a,b)
	ate (b <> 0)
	c <- a / b
	escreva ("O resultado da divisão é: ",c,"")
Fim

2 - VAR A,B,C:REAL 
inicio 
LEIA (A) 
LEIA (B) 
ENQUANTO B = 0 FACA 
ESCREVAL ("DIGITE VALOR DIFERENTE DE ZERO") 
LEIA (B) 
FIMENQUANTO 
ESCREVA (A/B) 
fimalgoritmo

1 - 

Você tem que fazer a consistencia logo após a entrada de dados, assim:

Inicio
	repita
		leia(a,b)
	ate (b <> 0)
	c <- a / b
	escreva ("O resultado da divisão é: ",c,"")
Fim

2 - VAR A,B,C:REAL 
inicio 
LEIA (A) 
LEIA (B) 
ENQUANTO B = 0 FACA 
ESCREVAL ("DIGITE VALOR DIFERENTE DE ZERO") 
LEIA (B) 
FIMENQUANTO 
ESCREVA (A/B) 
fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas